Modern Treasury - Modern Treasury App: Outage – Incident details

Modern Treasury App: Outage

Resolved
Major outage
Started 10 days agoLasted about 3 hours

Affected

Platform/API

Major outage from 8:28 PM to 8:40 PM, Operational from 8:40 PM to 11:06 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    Currently monitoring as functionality appears stable.

  • Investigating
    Investigating

    We are currently investigating this incident that is impacting pages across the web application.